Announcement

Collapse
No announcement yet.

7psi??

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 7psi??

    Well.. here's the situation -- I can only get 7 psi of boost.. I haven't pressure tested my plumbing so it may be the problem but I was wondering if it's possible i'm running too rich? I'm hitting an afr of about 9.5 at 7 psi... so.. is that a possibility... i have worries of detonation so I'm not eager to really push my tuning untill i get a proper knock sensor. oh yeah.. by timing is at 21 degrees at that point.
    8.5 custom arias pistons (.020 over)
    eagle rods
    t70 turbo (man was that a squeeze)
    38 mm external wastegate
    mild port/polish
    3 angle valve job
    custom intercooler piping
    twin external intakes with z32 maf
    rad moved back
    3" exhaust with only a resonator
    romulator
    420cc injectors
    custom body work, homemade oil lines and fittings..
    walbro 255lph in-line fuel pump.... and lots of headaches... lol

  • #2
    I dont even think the knock sensor does anything if you're controlling the boost by other means such as with an electronic or manual boost controller.
    88T => 300zxt

    http://www.300zxt.com

    Comment


    • #3
      9.5 is so rich I am shocked your engine will even fire. My engines won't run under boost richer than about 10.5, it sputters and backfires.

      Don't add extra fuel to kill the timing, adjust the timing maps or base after you've got the fuel set where you want it (high 11's for a high-boost street car).

      Comment


      • #4
        hehe... it was running at 8.3 earlier yesterday... i'll try and get the afr's up to 11.5.. but my k value already seems awfully low -- 0100hex. I am going to re-calibrate my wideband and double check everything today.
        8.5 custom arias pistons (.020 over)
        eagle rods
        t70 turbo (man was that a squeeze)
        38 mm external wastegate
        mild port/polish
        3 angle valve job
        custom intercooler piping
        twin external intakes with z32 maf
        rad moved back
        3" exhaust with only a resonator
        romulator
        420cc injectors
        custom body work, homemade oil lines and fittings..
        walbro 255lph in-line fuel pump.... and lots of headaches... lol

        Comment


        • #5
          `

          Comment


          • #6
            AWESOME info! thanks Bernard! I'm going to have to change the latency then as well i suspect... afrs are kind of weird and don't correspond to the map at all.. if i get it lean at idle then things don't work so well under boost... so i suspect my latency is slightly out. And I'm pretty sure my $40 BOV is causing me issues... I heard it bypass once today while at about 7 pounds of boost. However, I have managed to get the boost to 10 psi -- I found a couple of minor leaks that i was able to fix.
            8.5 custom arias pistons (.020 over)
            eagle rods
            t70 turbo (man was that a squeeze)
            38 mm external wastegate
            mild port/polish
            3 angle valve job
            custom intercooler piping
            twin external intakes with z32 maf
            rad moved back
            3" exhaust with only a resonator
            romulator
            420cc injectors
            custom body work, homemade oil lines and fittings..
            walbro 255lph in-line fuel pump.... and lots of headaches... lol

            Comment


            • #7
              t70 wrote: AWESOME info! thanks Bernard! I'm going to have to change the latency then as well i suspect... afrs are kind of weird and don't correspond to the map at all.. if i get it lean at idle then things don't work so well under boost... so i suspect my latency is slightly out. And I'm pretty sure my $40 BOV is causing me issues... I heard it bypass once today while at about 7 pounds of boost. However, I have managed to get the boost to 10 psi -- I found a couple of minor leaks that i was able to fix.
              What BOV do you have? I bought a cheaper HKS knock off on Ebay a little while back and while it looks identical and they claim it really is an HKS, there's no way I could have purchased a legit HKS unit brand new for $65. I'm just a little worried that it may give me problems as well.
              Originally posted by Andrew84zx
              tell her your car is so fast it will make her panties fly off
              545 RWHP & 540 RWTQ
              VG30ET.com Member

              Comment


              • #8
                http://cgi.ebay.ca/BLOW-OFF-VALVE-UNIVE ... dZViewItem
                .... That's the BOV I'm using. I am going to try and shim the spring.. but it would appear that the Bov is actually unpredictable. I have actually only heard it bypass once under boost, but I think it leaks randomly because my afrs sometimes are jumpy as boost increases and it shouldn't be from my map as it is fairly consistant.
                8.5 custom arias pistons (.020 over)
                eagle rods
                t70 turbo (man was that a squeeze)
                38 mm external wastegate
                mild port/polish
                3 angle valve job
                custom intercooler piping
                twin external intakes with z32 maf
                rad moved back
                3" exhaust with only a resonator
                romulator
                420cc injectors
                custom body work, homemade oil lines and fittings..
                walbro 255lph in-line fuel pump.... and lots of headaches... lol

                Comment


                • #9
                  t70 wrote: http://cgi.ebay.ca/BLOW-OFF-VALVE-UNIVE ... dZViewItem
                  .... That's the BOV I'm using. I am going to try and shim the spring.. but it would appear that the Bov is actually unpredictable. I have actually only heard it bypass once under boost, but I think it leaks randomly because my afrs sometimes are jumpy as boost increases and it shouldn't be from my map as it is fairly consistant.
                  How is your BOV mounted? Have you tried to test it without the BOV?

                  http://cgi.ebay.ca/ws/eBayISAPI.dll?Vie ... %3AIT&rd=1

                  That's my BOV that I plan on putting on when I get my piping ready to install. I'm just leary of it leaking as well.
                  Originally posted by Andrew84zx
                  tell her your car is so fast it will make her panties fly off
                  545 RWHP & 540 RWTQ
                  VG30ET.com Member

                  Comment


                  • #10
                    taht is a weird looking thing

                    Terrible idea putting those wheels on...

                    Comment


                    • #11
                      WaZZ300 wrote: taht is a weird looking thing
                      That's what I said about yours. LoL.
                      Originally posted by Andrew84zx
                      tell her your car is so fast it will make her panties fly off
                      545 RWHP & 540 RWTQ
                      VG30ET.com Member

                      Comment


                      • #12
                        Welll... I have not tried to run it without the bov. I'm going to try and pressure test my intercooler and make sure there aren't other leaks that i missed and then I'm going to shim the hell out of that bov. But first i've got to start working more on my map. As of right now though -- i'm back to work for 2-3 weeks so i'll be x-communicato for a while.
                        8.5 custom arias pistons (.020 over)
                        eagle rods
                        t70 turbo (man was that a squeeze)
                        38 mm external wastegate
                        mild port/polish
                        3 angle valve job
                        custom intercooler piping
                        twin external intakes with z32 maf
                        rad moved back
                        3" exhaust with only a resonator
                        romulator
                        420cc injectors
                        custom body work, homemade oil lines and fittings..
                        walbro 255lph in-line fuel pump.... and lots of headaches... lol

                        Comment


                        • #13
                          [quote]FlawleZ wrote:
                          Originally posted by WaZZ300
                          taht is a weird looking thing
                          That's what I said about yours. LoL.
                          I have a blow off valve? SICK!!!!!!

                          Terrible idea putting those wheels on...

                          Comment

                          Working...
                          X