Announcement

Collapse
No announcement yet.

half the turbo piping arrived today..

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • half the turbo piping arrived today..

    as I sent the turbo back out..

    I'm still missing the cobra-head, and the 3" stainless pipe, along with a few more coupler and clamps.

    I have to figure out the 1" to 3/4" adaptor for the PCV, but an afternoon at home depot should yield an answer tomorrow.

    I'm going to move the air filter to in front of the rad once the piping comes in... I'm running an AFCO, and have left plenty of space on that side of the rad, I'm already running my IC pipes through there.

    I don't think that it'll be a problem running the MAF that close to the turbo inlet, will it?


    oh, the coppermine uploader seems to be broken, btw.
    vg33et -blew some chunks outta it, then gave it all away.
    2009 370z touring/nav/sports

  • #2
    I never had a problem with the filter right on the maf, though sometimes idle would fluctuate a little bit because of air turbulence. I did have the screens removed from mine.

    The coppermine uploader works fine if your picture is not freaking huge. Resize that bitch to 1024x768 and try it again.

    Comment


    • #3
      Thanks!

      yeah.. I took that with my camera on the "small" setting..
      vg33et -blew some chunks outta it, then gave it all away.
      2009 370z touring/nav/sports

      Comment


      • #4
        the other half arrived. I may trim the pipe down to fit, if needed.. 2ft seems kinda too long.... I'll see on fit-up ;D

        vg33et -blew some chunks outta it, then gave it all away.
        2009 370z touring/nav/sports

        Comment


        • #5
          What exactly were you trying to make that look like? :-P

          Comment


          • #6
            lol, it is kinda phallic
            vg33et -blew some chunks outta it, then gave it all away.
            2009 370z touring/nav/sports

            Comment


            • #7
              just make sure you lube the filter adequately

              Comment

              Working...
              X