Announcement

Collapse
No announcement yet.

Electrical issue on 87ZX NT

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Electrical issue on 87ZX NT

    My dash warning lights are mostly not working correctly. Most of them stay "on" after start up and do not go out. I pulled fuses until I found the one that seems to be causing the problem. ( It was the one that controls the volt meter. ) Afterr I pulled the volt meter fuse, the dash lights went out. I'll need to find the problem in order to get the dash lights working correctly. I think, but am and not intirely sure,it just started after I replaced the both the motor sensors, the oil sending unit,and the climate control unit. I still have an issue with the dash temp gauge, which I have now got to working intermittantly. Changing the aforementioned sensors cleared up my oil sending gauge. I have not driven the car much, except to start it up to work on the gremlins. I had to have the rack & pinion rebuilt and need to install it yet. A bit of good news on this; the garage that I use was able to re-build it with a 50 dollar kit from Amazon. I could not find a reasonable re-built one on the Net- so this worked out OK. Any help you guys can provide me on this would be great !! BTW: I cleaned up all the ground wires on the car. I do not know if any of them were not connecting correctly- so I just fixed them with either new wires or sanding off the connecting areas- Many of them appeared to need cleaning up.

  • #2
    Jerry don't you just love chasing down Z31 gremlins. I have a shop in LA that my Z goes to every 2-5 years that know all the gremlins I just have a feeling that a shop like that would know what the hell is causing all of this. I couldn't get back-lights to come on it was my headlight switch, never would have thought. BTW, rebuild with $50 kit is amazing, I was into my rebuilt for like $1200 installed, but I live in Bay Area where the labor is $100 at aftermarket shop, Nissan stealership is like $200

    Comment


    • #3
      Ive seen this before. The alternator has a built in voltage regulator and has failed. Leaving it like this will cause damage to the electronics/ECM and will cook the battery since the voltage is not being regulated as it should. On the Z31.com site there is a page on information about dash warning lights staying on due to alternator voltage regulator failure, or total alternator failure causing battery to drain.

      Check voltage at the battery using a multimeter. With the engine idling and all loads OFF (headlights, blower off). Should NOT exceed 14.7 volts. Anything over that is bad as its only a 12 volt system. With headlights and blower on voltage should NOT go below 13.2 volts at idle.

      14.8+ volts means the voltage regulator is not doing its job properly anymore, this failure commonly causes all the warning lights to come on in the dash, pulling the volt gauge fuse eliminates the dash lights because you're basically shutting down the part of the system that monitors voltage.

      Also, I've seen alternator harness damage cause this same issue as well.

      I'd say, before tearing into wiring and stuff, perform a visual inspection of the alternator wiring and connectors, if OK condition, regardless of voltage readings at the battery, find a good alternator and swap it out and see what changes.

      P.S. The stock gauges are notoriously unreliable. Both the sensors and gauges fail, if you've replaced snesors and are still having gauge issues I'd say your issue is internal to the gauges or their wiring.

      P.S.S. You could attempt to repair your current gauges, find some good working originals (that will eventually fail again), or could try aftermarket gauges for your gauge issues.
      Last edited by Twisted`Z; 04-03-2021, 04:36 PM.

      Comment

      Working...
      X