Announcement

Collapse
No announcement yet.

Misfire, especially when cold. Vacuum leak?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Misfire, especially when cold. Vacuum leak?

    My 86NA has a slight misfire at idle. It does seem to get better as the vehicle warms up, but is still present even at operating temperature. However, I unplugged the MAF to put the car in limp mode, and it seemed to mostly eliminate the misfire. I haven't tried this with the engine cold, but would this possibly mean a vacuum leak somewhere could be a factor? I don't know what the likelihood of a vacuum leak causing a misfire.

    1986 300ZX N/A 5Speed project. Needs work, but that's the point, isn't it?

  • #2
    so many things it could be man... if it was me I'd get under there and try to figure out if it's a specific cylinder that's misfiring... check the plugs for an outlier... if you got a good ear and it's misifiring fairly steadily disconnect spark plug wires one at a time and see if you can localize that it's a specific cylinder. If it's not a specific cylinder then it's probably spark. Vacuum or exhaust leaks are a bad place to start, they are where you end up when you've eliminated more conclusive checks.

    edit - okay just saw your other post and if you've got a hacked harness and you deleted your idle stuff and you have ECU problems, vacuum leaks are the last thing you should be worrying about lol. Check for bad cylinders and verify that you're getting reliable spark first.
    Last edited by FrozenZ; 10-21-2019, 08:33 AM.

    Comment


    • #3
      I should have mentioned that I tried unplugging each plug wire to see if the idle would change. Basically, unplugging each wire you can clearly hear the rhythmic miss of whatever cylinder is unplugged, but I can't tell if unplugging one cylinder gets rid of the intermittent misfire. I have a new ECU in the mail as well. But the spark seems to be okay, because there is a clear difference when you unplug a wire and you can tell that each particular cylinder is not firing.

      1986 300ZX N/A 5Speed project. Needs work, but that's the point, isn't it?

      Comment


      • #4
        check all your injector connections, spark plug wires, how's the distributor cap&rotor? I'm just trying to make sure that you walk through all the easy-to-diganose stuff first.

        one thing, if you deleted your idle stuff you *are* gonna run rich at idle until the car is good and warmed up. sorry if I'm going really basic here, but you're sure that it's a misfire in the cylinder and not random popping in the exhaust (is your exhaust stock or aftermarkey?) Like, if the car's idling, you stand over it with the hood open, do you hear the misfire coming from the motor?

        Comment


        • #5
          Okay, I know it's been a while but I have some updates.

          -The injector connectors are new, and were wired in pre-campaign style.
          -The cap and rotor are new, as well as the plugs and wires.
          -No idle controls but I set the TB screw at about 850 and adjusted a new TPS with a new sub harness to the setting.
          -New oxygen sensor, I also had the manifolds repaired and installed them with new gaskets all around.
          -New OEM Nissan CHTS and subharness
          -Fuel pressure regulator was replaced prior to the misfire problem to get the car to start. However, this fpr has no fuel temp sensor installed.
          -New fuel pump relay, but pump doesn't turn off after 5 seconds/ at the click
          -ECU is "new" (to me) and is a 1986 N/A 5speed which is what the car originally was.
          -The CAS was replaced with a Pathfinder unit from the junkyard that was in good shape.

          So, with all that said the symptoms are still similar, but I think the misfire has improved. Once warmed up, I can drive the car around the neighborhood at least.

          However, no matter what I do the car is still hard to start cold. It will crank over, start to fire, and then die immediately if not given gas. It does this multiple times, but once warmed up it seems to start without trouble.

          Unplugging the MAF didn't seem to change the start behavior in any noticable way, nor did unplugging the O2 sensor or swapping to a different ECU.

          Of course, doing my reading on the forums seems to point to this as a classic CHTS issue. My problem is, I have a new OEM CHTS and subharness. As a test, I tried unplugging the CHTS and even then the start behavior didn't change. If I understand correctly, the CHTS resistance decreases with increasing temperature, so my thought was that perhaps no CHTS, "infinite" resistance, would put the car in cold start mode and it would maybe fire up better and then run rich later, confirming CHTS issues. However, since it didn't change anything I'm starting to think maybe I have a short in the harness or something.

          My next step then is going to be to try to test the signal from the CHTS on the ECU side and see if I'm getting good resistance values, or maybe TEMPORARILY install a dummy resistor to see if that changes things at all. I also have new cables for the battery, so I will replace the negative and positive cables to help make sure the electrical system is grounded and keep the electronics happy. Correlary to that, do the harness grounds all go to the upper intake manifold? That's where I have them installed currently but the battery grounds to the chassis.

          Other than that, I may check on the timing and make sure that is set correctly but if none of that works I'm at a loss. Just wondering if anyone has a suggestion or something that I overlooked.
          Last edited by designate72; 03-02-2020, 10:18 PM.

          1986 300ZX N/A 5Speed project. Needs work, but that's the point, isn't it?

          Comment

          Working...
          X