No announcement yet.

PRW2 install gone wrong

  • Filter
  • Time
  • Show
Clear All
new posts

  • PRW2 install gone wrong

    Asking on behalf of another SS owner that when he went to install the PRW2 upgrade module, swapped the wrong two wires and bricked his car. It cranks, but there is no spark at the coil.

    Unfortunately I've not had to troubleshoot anything like this personally, so i'm at a loss. I know he has tried a replacement: ECU, CAS, PRW2 module.

    I've been able to help in as far as i can look at the wiring schematic and see that the three wires from the module go to pins 3 & 5 of the ECU and ground, and that's where my experience ends.

    Sorry for the vague post, but i'm sure someone has done this before, i just don't know where to look for a failed part.

    84 AE/Shiro #683/Shiro #820/84 Turbo

  • #2
    Maybe try replacing the coil? Probably a long shot, only time I seen a z31 coil go bad was because it has a nice crack in it and its juices were leaking out.
    1986 Z31 2+0 Turbo GLL ---- spearco IC ,3" exhaust, Poly everything with solid subframe and diff mounts, HX35/40 Holset Turbo, CLSD, Nistune with 1220cc FIC injectors on E85.
    1993 Jeep Cherokee 4X4
    1995 Z32 2+0 NA Black
    1985 Z31 2+0 turbo Black
    1986 Z31 2+0 NA Red
    1988 Z31 2+2 NA Auto
    1988 Z31 2+0 Turbo White ---- Stripped for all of its goodies.
    1984 Z31 2+0 turbo Brown
    1985 Z31 2+0 NA Black
    2003 Nissan frontier D22 supercharded vg33e 4x4


    • #3
      He did try another coil but that didn't work. I he got it fixed by installing an unmodified replacement ECU (i guess the "spare" one he tried previously was a nistune modified ecu i had installed that might have other issues) The unmodified ECU got the car started. Unfortunately the ECU that was damaged was one i had loaned him : /

      84 AE/Shiro #683/Shiro #820/84 Turbo