Announcement

Collapse
No announcement yet.

1987 N/A turbo conversion HELP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1987 N/A turbo conversion HELP

    Hey guys I could really use some help with my Z31! I have a 1987 two seater I traded for a Honda when I was 18 it was N/A and it ran like a top for about three years. Somehow I managed to snap the pulley on my crankshaft, so my brother convinced me to do the turbo swap. I bought a running 1985 Z31 Turbo. I swapped the motor with the wiring harness still all connected, and brought the turbo ECU, and crossmember over to me car with it. I did keep my original transmission because or else I would have had to swap the entire driveline I believe. When I turn the key the starter cranks but my ignition coil does not get any power and neither does the fuel pump. I have wired the fuel pump directly up to power to ensure that it is working, it is. I did have some confusion when I was wiring up the alternator for some reason it seems like I have two sets of wires going to the alternator.. hmm.. I cant figure that one out. There was a hot wire that touched metal and made a huge spark the first night we tried starting it, it fried one of the fusible links located next to the battery I swapped all them out with the ones from my “parts car, 85 turbo Z” I tried to look for shorts in the system by having a tester light connected to the positive batter terminal ( disconnected from the batter) and the other end on the positive terminal, no luck. I have checked all the grounds that I could find they all seem to be connected well. One other weird thing my turbo ECU seems to be stuck in a certain mode, when I turn the mode selector clockwise with the ignition on the red and green lights do not blink together its as if their already shooting out codes, I tried to do the steps to reset it but it still does the same thing. I connected my N/A ECU just for shits the fuel pump nor the ignition coil still do not get power however that ecu seems to be functioning as far as the red and green lights blinking together to let me choose the mode and when I do go into mode 3 with the N/A ECU it gives me code 44 which I guess meens “no codes” “ normal operation, lol. This post is my last hope for this setup if I cannot figure this out then I am going to buy a stand alone ECU and go that route, however I would really prefer to use my tax return for suspension, but at this point I just want my fairlady to run, even if she does ride like a boat on land,lol. Any ideas would be much appreciated thanks for reading my post.

  • #2
    Try to start it with the NA ECU - don't drive it around or anything, just start it. AFAIK that should work. Then you'll know if your turbo ECU is dead or if you have other problems.

    Comment


    • #3
      incompetence, wiring mess

      long road ahead of rerigging you setup.. i'm not reading all that mess

      Comment


      • #4
        What I would do is first get the service manual, and then follow the diagnostic procedure for a code 21. This will walk you through checking the ignition system and wiring. Be thorough and just take it one piece at a time. I know it can be daunting at first, but just focus on one problem at a time. If you still have the fuel pump hot-wired, you can leave that diagnosis till later. Pay no attention to disgruntled trolls, we have all been where you are, not knowing where to start. Remember all circuits have a start and an end. If you start at one end and check everything along the circuit you WILL find the problem.
        GL
        Mike
        Butter (credit where credit is due): "You have this "gift" where you can make cooking a Hot Pocket seem like you need a certain wavelength microwave and involve brown mustard."

        Comment


        • #5
          I realize this is an old thread, but may be helpful for someone who comes across it in the same situation. I've done two turbo swaps where I brought the turbo efi wiring harness over with the vg30et rather than just swapping the injectors, oil pan etc. Both times I had no power to the coil. After studying the wiring diagram for the ecu in the fsm, I found there were some differences on the main harness of the NA vehicle and the Turbo vehicle from the coil to the ecu. This results in the wrong pin locations for these wires when you plug in the turbo ecu. After switching the pins around on the turbo efi harness (can't remember the exact changes to be made, you will want to look at the fsm, but the location of where the changes need to be made are with the plug on the efi harness that plugs in right above the ecu) I now had spark and problem was solved.
          Last edited by Z-Whipped; 08-16-2016, 06:36 AM.

          Comment


          • #6
            I know this is old but I think this is at the point where I am now. I’ll look at this connector tomorrow and compare the harnesses in the FSM. I’ve also brought over the efi harness with the turbo motor and have no power to the coil

            Comment

            Working...
            X